In queste ultime due settimane ho avuto la sfortuna di mandare in assistenza ben 3 prodotti Iomega IX2-200, mi si e’ rotto un disco al mio IX4-200d ed un IX2-200 non ne voleva sapere di partire ma essendo fuori garanzia  ho potuto fare poco con i tecnici Iomega.

Da questa esperienza ho imparato due cose :

  • Non mi piacciono piu’ i prodotti Iomega …
  • Adesso so come ripristinare il firmware di un IX2-200

La seconda cosa che ho imparato infatti e’ l’argomento principale di questo articolo.

Il problema dell’IX2-200, quello che non voleva partire era infatti che i dischi si erano rotti e all’accensione si sentiva il classico clank sordo, il led bianco cominciava a lampeggiare velocemente e l’unita’ non veniva riconosciuta in rete.

Il sistema operativo che a questo punto non so se per furbizia o per necessita’ tecnica e’ stato messo in una partizione da 2Gb in testa agli hard disk che non partivano quindi non veniva semplicemente caricato.

Ora, posso capire che per velocizzare l’OS o per risparmiare in qualche chip di memoria si adotti l’HDD per il firmware del NAS ma in caso di malfunzionamento di entrambi i dischi ci deve essere una soluzione di ripristino.

Sul sito ufficiale IOMEGA non c’e’ nulla che aiuta a ripristinare il firmware di un NAS con entrambi i dischi rotti e dal supporto tecnico in pratica mi hanno detto ciccia.

Se per caso abbiamo deciso di fare un upgrade dei dischi, che ne so da 1tb a 2tb non possiamo farlo perche’ sempre il sistema operativo e’ montato sulla prima partizione del disco e non vi sono procedure ufficiali.

Questa cosa non e’ accettabile, se scade la garanzia del prodotto dobbiamo sperare che MAI si rompano i dischi simultaneamente altrimenti non c’e’ modo ufficiale di rimettere su il NAS.

Spulciando la rete ho scovato questo workaround che ha funzionato …

Di cosa abbiamo bisogno

  • Firmware decriptato ix2-200 Cloud Edition Firmware 3.1.12.47838 scaricabile da SendSpace o RapidShare*
  • Penna USB con 2Gb ed un indicatore LED di funzionamento **
  • Adattatore SATA / USB
  • Stuzzicadenti ***
Come si procede
  • Se state montando dischi nuovi magari di dimensioni maggiori e’ tutto okay. Diversamente dovete cancellare le partizioni presenti sugli Hard Disk (utilizzate un adattatore SATA / USB) ed uno dei tanti software per la gestione delle partizioni
  • Inserite nuovamente i dischi negli alloggiamenti 1 e 2
Preparazione Penna USB
  • Formattare la USB Pen Fat32 (anche la formattazione veloce va bene).
  • Creare sulla USB Pen una cartella chiamata emctools all’interno della quale bisogna creare una cartella chiamata ix2-200d_images (avete quindi un percorso assoluto del tipo x:\emctools\ix2-200d_images)
  • Copiare il file ix2-boot.tgz scaricato nella cartella ix2-200d_images
Aggiornamento Firmware
  • Se accesa, spegnete l’unita’.
  • Scollegare il cavo ethernet
  • Inserire la USB Pen in una porta USB
  • Inserire lo stuzzicadenti nel foro reset
  • Inserire lo spinotto di alimentazione
  • A questo punto si accende il NAS, dopo pochi secondi si accende il led bianco che comincia a lampeggiare. Dopo circa 30 secondi si sente il rumore degli HDD che partono, continuando a premere il reset aspettare circa 1 minuto finche il led bianco rimane fermo.
  • Aspettare finche il led della penna USB comincia a lampeggiare e rilasciare il tasto reset. Il NAS comincera’ la fase di decompressione dell’immagine del firmware e successivamente la installera’ sugli HDD. Fatto questo il sistema si spegne automaticamente.
Post aggiornamento
  • Scollegare la USB Pen
  • Ricollegare il cavo ethernet
  • Riaccendere il NAS
  • All’accensione il NAS parte con la ricostruzione del RAID che impiega parecchio tempo ma comunque la GUI deve essere raggiungibile via browser. Qualora questo non fosse possibile bisogna cancellare il contenuto della cartella x:\emctools\ix2-200d_images\temp e ripetere l’operazione di aggiornamento firmware.

A me l’operazione di aggiornamento e’ andata a buon fine alla prima prova, dopo aver riavviato il NAS ed aspettato che ricostruisse il raid ho scaricato l’ultima versione del firmware ed ho proceduto con l’aggiornamento.

Risultato finale

Ho un nas perfettamente funzionante con dischi di capacita’ doppia rispetto al modello originale (ho usato 2 x WD20EFRX da 2tb) ed ho la nuova versione del fimware (attualmente versione 3.2.6.21659).

Link fonte originale : Upgrading Iomega ix2-200 to Cloud Edition

Written by Alberico Schiappa

Ciao, spero che questo articolo ti sia piaciuto. Ti chiedo un click per aiutarmi a condividerlo sui Social Network e se puoi, di commentarlo con le tue esperienze e suggerimenti...

This article has 169 comments

  1. Giuseppe Reply

    Salve,
    Ho letto con molto interesse questa discussione perche anch’io ricado fra coloro che sono rimasti “fregati” dal nas iomega io possiedo un home media cloud edition con un solo disco da 2 Tb che però ha deciso di non partire più. In breve ho tentato di eseguire l’ggiornamento firmware direttametne dal suo software di gestione interno e credo non sia andato a buon fine da allora però ha continuato a funzionare piu o me no bene per un bel po di tempo. da circa una settimana ha però smesso di essere riconosciuto dalla rete ed ho notato dopo averlo smontato e ispezionato sotto una live di ubuntu che delle 3 partizioni presenti; una è vuota la seconda da 20 Gb circa non so cosa ci sia dentro e l’altra (spero) contiene ancora tutti ida ti integri.
    io desidererei solo recuperare i dati, poi posso pure buttare il nas !
    Ho già provato a leggere i drive dalla live di ubuntu ma non me li monta e/o fa leggere
    Grazie per qualunque consiglio vogliate darmi

      • Fabio Reply

        Complimenti articolo interessante, ho lo stesso problema, un disco è andato, fortunatamente era in raid 1 e i dati sono salvi, ma non sapevo come ripristinare il disco danneggiato in quanto l’assistenza non fornisce informazioni fuori garanzia neanche a pagare (veramente disonesti).
        Seguendo lattua procedura, vorrei mettere due wd Red da 1 o 2 tb, funzionerebbe oppure occorre mettere gli stessi segare barracuda originali?

      • fabio Reply

        Salve.
        ho seguito con interesse la spiegazione del ripristino del nas iomega.
        Io ho un problema analogo:
        Iomega ix2 200 cloud, 1 tb in mirroring raid1, purtroppo 1 HD si è dabneggiato.
        Compro 2 wd red da 2 tb ciascuno, clono l’hd buono del nas da 1 tb, su un hd red da 2 tb nuovo di pacca.
        Inserisco l’hd red 2 tb clone nel nas e il secondo hd red vergine.
        Il nas si avvia tranquillamente ed effettua il mirroring del 2 hd red.
        PROBLEMA:
        Il nas vede come dimensione 1 tb non 2 tb come realmente è.
        qualcuno saprebbe dirmi perchè e come fare per avere per risolvere?
        Grazie

        • alberico schiappa Reply

          Tu sei passato per un clone HDD quindi le dimensioni della partizione da 1Tb sono state riportate sul disco da 2Tb allo stesso modo. Successivamente il raid ha replicato questa situazione sull’altro disco.

          Diversamente, se avessi montato i due dischi da 2Tb sotto il NAS e seguito la procedura avresti 2Tb a disposizione per in fase di formattazione l’os prende il massimo dello spazio per la partizione dati …

          Il mio consiglio, se hai tempo e voglia :

          copia tutti i dati su un altro supporto
          prova la procedura di ripristino sul raid da 2TB
          ripristina i dati

          1) se va male hai sempre il disco da 1tb con i dati dentro e puoi rifare da zero
          2) se va bene hai 2Tb in linea e puoi formattare il disco da 1tb vecchio

    • Antonio Reply

      Ciao a tutti e Buon Natale.

      Ti posso chedere le dimensioni e la tipologia delle 3 partizioni? Anche a me succede la stessa cosa ma a differenza rilevo 2 partizioni e 32 mega non allocati. Ho letto in giro che in quei 32 mega ci va il boot. Ma come devono essere formattati? Mica avete i file di boot? io ho qualcosa trovato qui …
      http://iomega.nas-central.org/wiki/Recovery_(Home_Media_CE)
      … il mio hd è un Lenovo Ez Media da 1 TB

      p.s. ho scritto anche alla Lenovo … sono in attesa di una risposta

      • alberico schiappa Reply

        Ciao :) Credo che LENOVO difficilmente rispondera’ se non con un copia / incolla di qualche letterina appositamente creata per chi vuole rompere le scatole (a loro avviso) … Se hai salvato i dati presenti nelle partizioni dati cancella tutto e segui la procedura. Se non vi sono problemi di m/b o di HDD dovrebbe funzionare tutto. Salutoni

  2. Luciano Reply

    Salve,
    posseggo uno Iomega Storcenter ix2-200 (con dischi da 2 tera originali) sul quale ho provato la procedura suscritta, con installato un solo hard disk con partizione cancellata. Il led bianco resta lampeggiante per tutto il tempo, anche dopo la partenza dell’hard disk, non c’è modo che smetta, eppure ho seguito la procedura come descritta. C’è qualcos’altro che posso provare o devo obbligatoriamente utilizzare i dure hard disk insieme?
    Grazie anticipate,
    Luciano

    • alberico schiappa Reply

      Ciao :) scusa per il tempo nel risponderti ma ultimamente sono un po’ impegnato. Allora, se ho capito bene hai pulito un HDD e provato senza successo la procedura con solo 1 HDD nel NAS. Non saprei che dirti se non provare con entrambi e fare attenzione alla cartella temp sulla usb pen come suggerito anche da altri perche’ sia con me che con altri ha funzionato. Gli HDD sono a posto immagino …

  3. massimo Reply

    Ciao volevo chiederti sie per caso questa procedura e questi files vanno bene anche per un ix-2, se no sapresti darmi indicazioni in merito?
    ho avuto un problema con un disco e l’ho sostituito e da allora non ha più funzionato. Non mi arrendo e voglio ripristinarlo, cosa mi consigli?

    Grazie

    • alberico schiappa Reply

      Non posso dirti con esattezza che la procedura funzioni con il modello IX2 ma credo che l’hardware che ci sta’ sotto sia lo stesso. Partendo da questo punto e dal fatto che comunque non ti funziona c’e’ poco da chiacchierarci su prova tanto male che va non succede niente :) Facci sapere se comunque ha funzionato …

  4. enzo Reply

    ciao grazie per l’articolo, volevo sapere se con questo nuovo firmware esiste la funzione cestino, sarebbe utile.

    grazie

  5. alberico schiappa Reply

    Stavo controllando alcuni settaggi sul mio IX4-200d quando ho letto “non e’ stato possibile contattare il sito per controllare gli aggiornamenti” …

    Giusto per curiosita’ ho messo nel browser http://www.iomega.com e non c’e’ piu’ … ahahahah!!! Chiunque ha prodotti marcati Iomega ma anche EMC o Lenovo puo’ stare sicuro che il supporto NON esiste (non so come si comporti Lenovo ma ormai la mia fiducia e’ passata ad altri brand).

    Quindi, se non riuscite a ripristinare il vostro “vecchio” IX2-200 forse e’ il momento di utilizzarlo per qualcosa di piu’ concreto. Sono sicuro che avete a casa una porta che tende a chiudersi … bene ecco trovato un buon sistema per utilizzare il NAS Iomega, un eccellente “fermaporte” …

    Se volete acquistare un buon NAS ecco i miei brand preferiti : QNAP e Synology … gli altri neanche li prendo in considerazione.

    Ecco un vecchio articolo che puo’ essere di aiuto : http://www.defaultuser.net/prova-online-due-potenti-software-per-nas/#.VpFiHvnhC70

    Vi assicuro che dall’articolo i software di gestione ne hanno fatto di strada. Gia’ completi e performanti adesso hanno raggiunto un livello di altissima qualita’.

    • Flavio Reply

      Ciao, volevo comprare un NAS Iomega StorCenter ix2-200 usato mancante di hardisk.
      Seguendo le tue istruzioni dovrei essere in grado di ripristinare il firmaware, ma volevo sapere se il NAS monta hardisck IDE o SATA? Da 2,5″ o 3,5″? e se possono essere montati di diversa capienza, tipo uno da 200GB e uno da 500GB.
      Grazie

      • alberico schiappa Reply

        Ciao, credo che dopo tutti questi commenti non proprio positivi non potesse esistere un temerario che volesse provare queste esperienze … I dischi sono SATA, anche se non ho conferme non credo si possano usare dischi diversi di capacità (anche se il raid di dovrebbe creare in automatico sulla grandezza del più piccolo). Sei veramente sicuro di voler provare questo brivido ??

  6. Alfredo Reply

    Salve, complimenti per l’articolo. Ho una domanda da porle. Ho pure io un nas del genere in azienda. Da noi si è guastato.un disco da 500 gb da 5900 rpm.
    Ho contattato lenovo e non sanno nulla, posso sostituire il disco con un 5200? non è facile reperire un disco del genere.
    Oppure posso optare nella soluzione da lei proposta, ma la velocità dei disci come deve essere? grazie.

    • alberico schiappa Reply

      Guarda, ormai ne ho lette e sentite di tutti i colori. Se non trovi lo stesso disco o uno similare mettine uno che si avvicina … in qualche caso hanno messo 7200rpm. Alla fine e’ il NAS che controlla la lettura/scrittura non e’ che il disco che va piu’ lento intralcia l’altro, semplicemente quello piu’ veloce acceso h24 si rompe prima …

      Puoi optare per 1 disco da 500gb (magari WD RED o GREEN) oppure 2 x 1-2TB WD RED o GREEN e fare la procedura supra descritta che tra l’altro ho rifatto pochi giorni fa su un IX2-200 ed ha funzionato.

  7. Mattia Reply

    ciao.
    ho seguito le istruzioni e ho aggiornato il NAs ma adesso ho la versione del firmware a 6.0.32 e non si tratta più di Iomega ma di Twonky Server…è tutto ok oppure ho installato un firmware sbagliato?

  8. Sebastiano Reply

    UPGRADE RIUSCITO
    Inizio intanto ringraziando Alberico e tutti coloro che hanno partecipato alla discussione che con i loro suggerimenti mi hanno permesso di recuperare e soprattutto notevolmente migliorare un Hardware che pensavo di dover “buttare alle ortiche”.
    Come da titolo sono riuscito ad effettuare l’upgrade, però ho dovuto apportare qualche variazione alla procedura suggerita.
    Invece di effettuare il boot dalla chiavetta usb con tutte due i dischi inserite nella NAS , ho inserito un solo disco nella NAS, la chiavetta usb (con il boot scaricato dal link suggerito) nella porta anteriore, staccato il cavo di rete, premuto il tastino di reset con lo “stuzzicadenti” e riattaccata l’alimentazione e seguita la procedura come spiegata da Alberico.
    Effettuata l’istallazione, collegato il cavo di rete, fino al punto di vedere il disco disponibile dalla GUI, ho spento tutto, estratto e disinstallato l’HD dalla NAS, ho inserito il 2° nuovo HD nella NAS e effettuata nuovamente la procedura con la chiavetta usb. fino a vedere anch’esso dalla GUI nel Browser.
    A questo punto ho spento tutto di nuovo, inseriti entrambi gli HD nella NAS, acceso e configurato il RAID1 dalla GUI. Attenzione inizialmente il led centrale rimane ROSSO fino a quando non inizia la configurazione del RAID1 (che dura diverse ore).

    Ciao a tutti, buon lavoro e tanta pazienza .

  9. Sebastiano Reply

    Dimenticavo, ho istallato due nuovi HD da 2 TB ciascuno, produttore Western Digital, serie RED, modelle WD20EFRX.
    In origine c’erano due dischi da 1 TB Seagate.

    Ciao

  10. VALTER Reply

    buona sera…..GRAZIE 1000 problema risolto, era da tanto che cercavo la soluzione..ancora grazie ….

  11. aurelio Reply

    Ciao a tutti, provo con firmware a far ripartire 4 nas ix2 dati per morti. se volete e mi dite come fare ho un ix4 stor centre pro funzionante dal quale tirare fuori il sistema se a qualcuno può essere utile.

    • alberico schiappa Reply

      La procedura sopra descritta e’ stata piu’ volte utilizzata con successo … io sinceramente dopo anni e rotture varie alla fine ho buttato 2 IX-2 1 IX-4 che avevo ed ora sono un felicissimo possessore di QNAP … se vuoi divertirti o innervosirti segui la procedura oppure portali al centro smaltimento piu’ vicino :)

      Non vorrei sbagliarmi (probabile pero’) ma con lo stesso firmware di questo articolo ho fatto ripartire un IX-4 tempo fa …

  12. Antonio De Curtis Reply

    Procedura descritta perfettamente e di facile esecuzione
    Ho così recuperato una unità ix2-200 con 2 HDD guasti.
    Ora funziona benissimo.
    Grazie !

  13. shado Reply

    Una domanda……sai per caso se è possibile formattare i dischi dell’ x2 in formato ext3 linux ?!?
    Il problema che ho avuto modo di notare presso un cliente, è che non accetta la modifica del creatore del file.
    Da linux se utilizzi cp -av ti porti dietro i permessi e soprattutto il creatore del file, essendo formattati in ntfs ciò non avviene e dà delle scoccianti warning.
    Ti ringrazio per l’eventuale risposta

    • alberico schiappa Reply

      Ciao, come accennato in diverse risposte per me il brand Iomega e’ ormai morto e sepolto. Se “per caso” si riesce a ripristinare la funzionalita’ di un IX2 attraverso questa procedura io mi riterrei gia’ fortunato di poter utilizzare un pezzo di ferro per un altro periodo di tempo. Rimango dell’idea che ormai un prodotto di oltre 5 anni possa andare in pensione … nel tempo ho approcciato a QNAP che ti assicuro sono delle soluzioni bellissime. Nel frattempo puoi comunque utilizzare il NAS iomega. I miei sono ormai tutti rotti, anzi c’e’ ancora un Buffalo Terastation che si ostina a non morire ma che mi da un sacco di noie …

  14. baudo Reply

    grazie dell’articolo, l’unico che forse possa davvero darmi una mano poiché ho un problema analogo pure io con l’IX2-200 che comunque non ricomprerei più neanche me lo regalassero, ovviamente soluzioni migliori tipo QNAP..
    Comunque, il problema è che non riesco a trovare dai link un Firmware decriptato ix2-200 Cloud Edition Firmware 3.1.12.47838 o simile, hai per caso un altro link oppure si può spedire, che so, via File Transfer?
    Grazie per l’aiuto

  15. baudo Reply

    ciao e grazie per qualsiasi tipo di aiuto in ogni caso, forse ho già scritto nel forum ma siccome non vedo il messaggio (in approvazione??) e sto rimbalzando da un forum all’altro da alcuni gioni e letteralmente impazzendo riscrivo brevemente ciò di cui avrei bisogno, se fosse possibile: un LINK funzionante oppure una spedizione (che so, con Filetrasfer) del firmware poiché il [Firmware decriptato ix2-200 Cloud Edition Firmware 3.1.12.47838] di cui si parla sopra non è più scaricabile da quei link segnalati.. mi basterebbe questo, poi continuerò ad impazzire con il mo nas, se va bene altrimenti lo uso come fermaporte, dato che è robusto.. hehe
    Grazie infinite e comunque complimenti a tutti per la pazienza e in futuro.. –> qnap!!!
    :_)))

  16. sergio Reply

    Buongiorno Alberico, complimenti per il blog.
    Ho un iomega storecenter IX2 con 2 dischi da 1 tb cadauno in raid mirror.
    Si è rotto il disco 2, fortunatamente il nas continua a funzionare “con la spia rossa accesa” e mi sembra di non aver perso dati. Non essendo esperto mi sono venuti alcuni dubbi: il disco rotto è un seagate sata II da 1 TB 5900 rpm, posso metterci un disco sata III 7200 rpm che lo pago meno? – devo cercare dischi con specifiche particolari? -devo aggiornare il firmware per forza? – a parte un backup, prima di fare la sostituzione devo prendere accorgimenti particolari?
    Grazie

    • alberico schiappa Reply

      Tendenzialmente non dovrebbero esserci problemi con un disco da 7200rpm anche se sarebbe opportuno avere dischi uguali per cui se metti uno da 7200 ti consiglierei una volta ricostruito il raid di smontare l’altro riaccendere il dispositivo cosi si arrabbia che manca un disco, rispegnerlo e mettere un altro disco da 7200. Io normalmente nei NAS (uso ormai QNAP da diversi anni dopo le brutte esperienze avute con gli IOMEGA) metto WD RED a 5400rpm che sono stati fatti apposta per i NAS. Sono a bassa rotazione in modo da consumare poco e “si spera” rompersi solo nel lungo periodo. Finora non ho avuto particolari problemi. Aggiornare il firmware sarebbe cosa buona e giusta ma se hai un disco a 5900 ed uno a 7200 gia’ ce n’e’ di differenza, poco importa il firmware :)

  17. Carlo Reply

    Ciao,
    so che questo post è un pò vecchiotto, ma volevo solo ringraziarti perchè seguendolo sono riuscito a “recuperare” un NAS Iomega di un amico.
    Ho seguito le tue istruzioni ed è andato tutto, al primo colpo.
    Quindi complimenti per la guida dettagliata e precisa. :-)

Leave a Comment

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.