In queste ultime due settimane ho avuto la sfortuna di mandare in assistenza ben 3 prodotti Iomega IX2-200, mi si e’ rotto un disco al mio IX4-200d ed un IX2-200 non ne voleva sapere di partire ma essendo fuori garanzia  ho potuto fare poco con i tecnici Iomega.

Da questa esperienza ho imparato due cose :

  • Non mi piacciono piu’ i prodotti Iomega …
  • Adesso so come ripristinare il firmware di un IX2-200

La seconda cosa che ho imparato infatti e’ l’argomento principale di questo articolo.

Il problema dell’IX2-200, quello che non voleva partire era infatti che i dischi si erano rotti e all’accensione si sentiva il classico clank sordo, il led bianco cominciava a lampeggiare velocemente e l’unita’ non veniva riconosciuta in rete.

Il sistema operativo che a questo punto non so se per furbizia o per necessita’ tecnica e’ stato messo in una partizione da 2Gb in testa agli hard disk che non partivano quindi non veniva semplicemente caricato.

Ora, posso capire che per velocizzare l’OS o per risparmiare in qualche chip di memoria si adotti l’HDD per il firmware del NAS ma in caso di malfunzionamento di entrambi i dischi ci deve essere una soluzione di ripristino.

Sul sito ufficiale IOMEGA non c’e’ nulla che aiuta a ripristinare il firmware di un NAS con entrambi i dischi rotti e dal supporto tecnico in pratica mi hanno detto ciccia.

Se per caso abbiamo deciso di fare un upgrade dei dischi, che ne so da 1tb a 2tb non possiamo farlo perche’ sempre il sistema operativo e’ montato sulla prima partizione del disco e non vi sono procedure ufficiali.

Questa cosa non e’ accettabile, se scade la garanzia del prodotto dobbiamo sperare che MAI si rompano i dischi simultaneamente altrimenti non c’e’ modo ufficiale di rimettere su il NAS.

Spulciando la rete ho scovato questo workaround che ha funzionato …

Di cosa abbiamo bisogno

  • Firmware decriptato ix2-200 Cloud Edition Firmware 3.1.12.47838 scaricabile da SendSpace o RapidShare*
  • Penna USB con 2Gb ed un indicatore LED di funzionamento **
  • Adattatore SATA / USB
  • Stuzzicadenti ***
Come si procede
  • Se state montando dischi nuovi magari di dimensioni maggiori e’ tutto okay. Diversamente dovete cancellare le partizioni presenti sugli Hard Disk (utilizzate un adattatore SATA / USB) ed uno dei tanti software per la gestione delle partizioni
  • Inserite nuovamente i dischi negli alloggiamenti 1 e 2
Preparazione Penna USB
  • Formattare la USB Pen Fat32 (anche la formattazione veloce va bene).
  • Creare sulla USB Pen una cartella chiamata emctools all’interno della quale bisogna creare una cartella chiamata ix2-200d_images (avete quindi un percorso assoluto del tipo x:\emctools\ix2-200d_images)
  • Copiare il file ix2-boot.tgz scaricato nella cartella ix2-200d_images
Aggiornamento Firmware
  • Se accesa, spegnete l’unita’.
  • Scollegare il cavo ethernet
  • Inserire la USB Pen in una porta USB
  • Inserire lo stuzzicadenti nel foro reset
  • Inserire lo spinotto di alimentazione
  • A questo punto si accende il NAS, dopo pochi secondi si accende il led bianco che comincia a lampeggiare. Dopo circa 30 secondi si sente il rumore degli HDD che partono, continuando a premere il reset aspettare circa 1 minuto finche il led bianco rimane fermo.
  • Aspettare finche il led della penna USB comincia a lampeggiare e rilasciare il tasto reset. Il NAS comincera’ la fase di decompressione dell’immagine del firmware e successivamente la installera’ sugli HDD. Fatto questo il sistema si spegne automaticamente.
Post aggiornamento
  • Scollegare la USB Pen
  • Ricollegare il cavo ethernet
  • Riaccendere il NAS
  • All’accensione il NAS parte con la ricostruzione del RAID che impiega parecchio tempo ma comunque la GUI deve essere raggiungibile via browser. Qualora questo non fosse possibile bisogna cancellare il contenuto della cartella x:\emctools\ix2-200d_images\temp e ripetere l’operazione di aggiornamento firmware.

A me l’operazione di aggiornamento e’ andata a buon fine alla prima prova, dopo aver riavviato il NAS ed aspettato che ricostruisse il raid ho scaricato l’ultima versione del firmware ed ho proceduto con l’aggiornamento.

Risultato finale

Ho un nas perfettamente funzionante con dischi di capacita’ doppia rispetto al modello originale (ho usato 2 x WD20EFRX da 2tb) ed ho la nuova versione del fimware (attualmente versione 3.2.6.21659).

Link fonte originale : Upgrading Iomega ix2-200 to Cloud Edition

Written by Alberico Schiappa

Ciao, spero che questo articolo ti sia piaciuto. Ti chiedo un click per aiutarmi a condividerlo sui Social Network e se puoi, di commentarlo con le tue esperienze e suggerimenti...

This article has 186 comments

  1. Crackers Reply

    ciao scusate ma il modello ix2-200 ed il ix2-200 cloud edition sono identici ma cambia solo il FW??

    Perché non riesco a capire che modello ho :) ho recuperato questo nas che buttava un amico ma hdd morti entrambi…

    Hard disk va bene formattato in ntfs con una unica partizione?

    • Alberico Schiappa Reply

      Ciao, se non ricordo male ho installato il firmware dell’articolo su un normale ix2-200 e se l’e’ preso senza problemi (a parte il casino che ci vuole per fare l’installazione). PEr quanto riguarda di dischi poi ci pensa lui ad azzerarli e creare il raid. Salutoni :)

  2. Andrea Reply

    Si puo’ fare anche con un solo disco funzionante.
    Sul ix2-200 (senza la d), la luce bianca non rimane fissa ma continua a lampeggiare, porre quindi attenzione solamente alla chiavetta USB, quando inizia a lampeggiare, lasciare il tasto reset.
    Un Saluto

  3. Leonardo Montuori Reply

    Ringrazio Alberico per aver aperto questa pagina e avendo risolto con il mio ix2-200 pubblico il mio contributo.

    Durante le operazioni ho visto cosa succedeva all’interno del dispositivo tramite collegamento seriale JTAG e terminale seriale.

    Segnalo che alcune penne USB non funzionano credo per tipologia o dimensione (nel mio caso una da 8GB non veniva vista in modo corretto). Io ho usato una da 1 GB che nel primo caso non ha completato la procedura e nel secondo caso ha funzionato in modo corretto).

    Dopo averla completata dal menu System / Update ho provato tutte le image disponibili e identificato l’ultima correttamente funzionante ossia la ix2-200-3.2.16.30221.tgz

    Buon recupero a tutti.
    Leonardo

  4. Wolly Reply

    Ciao, il led bianco del mio nas non smette di lampeggiare, cosa posso fare? E’ da buttare?

  5. Matteo Troiano Reply

    Probabilmente non sarà di aiuto a nessuno, ma dopo diversi anni, ho dovuto sostituire un disco del mio ix2-200. Lo avevo fatto in passato per passare alla Cloud Editions, ma non ricordando la procedura, ho cercato, trovato e seguito la procedura qui descritta. Risultato? Non funzionava, al punto che ho pensato che si fosse danneggiata la scheda madre del NAS. Poi pero’, caparbio e da ex informatico, ho cercato ancora sul web e ho trovato che in alcuni casi, la directory dentro e emctools deve essere “ix2-200_images” e non “ix2-200d_images”… Risultato? dopo aver cambiato nome alla directory, funzionato a primo colpo. Magari puo’ essere di qualche utilità a qualcuno, che non ci e’ riuscito a causa di questo “piccolo” particolare.

Leave a Comment

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.